排查 Windows 更新错误0x8024002E
发布时间:2026-08-21 | 浏览:2
访问此页面需要授权。 可以尝试 登录 或 更改目录 。
访问此页面需要授权。 可以尝试 更改目录 。
适用于: Supported versions of Windows Server
Windows 更新错误0x8024002E指示不允许访问非托管服务器,通常是因为服务器上禁用了 Windows 更新客户端服务。 本文档提供用于识别和解决此问题的步骤。
确保对服务器具有管理访问权限,以修改系统设置和策略。
若要识别问题,请检查 CBS.log 、 CbsPersist_XXXXXXXXXXXXXX.log 或 CbsPersist_XXXXXXXXXXXXXX.cab 文件以获取类似于以下内容的条目:
禁用 Windows 更新客户端服务时,会发生错误代码0x8024002E,从而阻止访问非托管服务器。 此问题通常是由于禁用 Windows 更新访问的组策略设置导致的。
启用 Windows 更新服务
按 Win + R 打开 “运行 ”对话框,键入 services.msc 并按 Enter 。
在 “服务” 窗口中,找到 Windows 更新 。
右键单击 Windows 更新 并选择“ 属性 ”。
将 启动类型 设置为 “手动 ”,然后选择“ 启动 ”。
本部分、方法或任务包含说明如何修改注册表的步骤。 如果您错误地修改注册表,可能会出现严重问题。 因此,请确保仔细执行这些步骤。 出于防范目的,请在修改之前备份注册表,以便在出现问题时还原注册表。 有关如何备份和恢复注册表的更多信息,请参见 如何在 Windows 中备份和恢复注册表 。
按 Win + R 打开 “运行 ”对话框,键入 regedit 并按 Enter 。
按 Win + R 打开 “运行 ”对话框,键入 regedit 并按 Enter 。
导航到 HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\DisableWindowsUpdateAccess 。
导航到 HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\DisableWindowsUpdateAccess 。
如果该值设置为 1 ,请将其 0 更改为启用服务。 注释 建议尽可能通过组策略管理此设置。
如果该值设置为 1 ,请将其 0 更改为启用服务。
建议尽可能通过组策略管理此设置。
按 Win + R 打开 “运行 ”对话框,键入 gpedit.msc 并按 Enter 。
导航到 Computer Configuration\Administrative Templates\System\Internet Communication Management\Internet Communication settings\ 。
请禁用 关闭对所有 Windows 更新功能的访问 策略。
打开 控制面板 并导航到 Windows 更新 。
尝试通过更新小程序手动修补服务器。
如果手动修补失败,请与设备和部署团队协作以获取进一步帮助。
想要尝试使用 Ask Learn 阐明或指导你完成本主题?
Last updated on 2026-02-12